diff options
author | Guilhem Moulin <guilhem@fripost.org> | 2015-03-30 14:31:37 +0200 |
---|---|---|
committer | Guilhem Moulin <guilhem@fripost.org> | 2015-03-30 14:32:02 +0200 |
commit | d68b581ea0d8b26191389e38032b599142c041c3 (patch) | |
tree | c129f83da3bed68883784123e14c7299db81699a | |
parent | 191534738adae255565eb3e9d7da3b976dc7ec73 (diff) |
Add installation intructions.
-rw-r--r-- | INSTALL | 21 |
1 files changed, 21 insertions, 0 deletions
@@ -0,0 +1,21 @@ +To install the CLI and Iceweasel/Firefox addon, run (requires 'gzip' and +'zip'): + + make -C cli + sudo make -C cli install + + make -C xul-ext ../icevault@guilhem.org.xpi + cp icevault@guilhem.org.xpi ~/.mozilla/firefox/*.default/extensions + + +However users familiar with Debian packaging will probably prefer to +build their own package: + + git checkout debian + AUTO_DEBSIGN=no git buildpackage --git-force-create + VERSION=$(sed -nr '/^icevault \(([^)]+)\).*/ {s//\1/p;q}' debian/changelog) + sudo dpkg -i ../icevault_${VERSION}_all.deb ../xul-ext-icevault_${VERSION}_all.deb + +(Add the option '--git-upstream-tree=BRANCH' to the 'git buildpackage' +command to package the development version rather than the last tagged +release.) |