aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Moulin <guilhem@fripost.org>2019-12-15 03:43:28 +0100
committerGuilhem Moulin <guilhem@fripost.org>2019-12-15 03:45:48 +0100
commit97b077be640071363918a0a27b0acfddd114ff1a (patch)
treed4dfe820e5bc495bcf8770b701646067c83c306e
parente1fadaaa8f8762a10ab24bb278759f3223837002 (diff)
Apply patches from master.debian/0.5_rc-2
In an attempt to fix FTBFS (`make -j4 test` failure) on the buildds.
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/tests-run-Don-t-redirect-stderr-by-process-substitut.patch34
-rw-r--r--debian/patches/tests-t-Increase-timeout-from-2-to-5s-after-backgrou.patch68
4 files changed, 110 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d19301..7ff1de4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+interimap (0.5~rc-2) experimental; urgency=low
+
+ * Apply patches from master to make the test suite pass on the buildds.
+
+ -- Guilhem Moulin <guilhem@debian.org> Sun, 15 Dec 2019 03:44:27 +0100
+
interimap (0.5~rc-1) experimental; urgency=low
* New upstream release. Closes: #942725, #944812, #944859.
diff --git a/debian/patches/series b/debian/patches/series
index 649d1d8..e7fcfbe 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,4 @@
Ignore-custom-lib-PATH.patch
Mention-the-Debian-BTS-in-the-manpages.patch
+tests-t-Increase-timeout-from-2-to-5s-after-backgrou.patch
+tests-run-Don-t-redirect-stderr-by-process-substitut.patch
diff --git a/debian/patches/tests-run-Don-t-redirect-stderr-by-process-substitut.patch b/debian/patches/tests-run-Don-t-redirect-stderr-by-process-substitut.patch
new file mode 100644
index 0000000..1a300f2
--- /dev/null
+++ b/debian/patches/tests-run-Don-t-redirect-stderr-by-process-substitut.patch
@@ -0,0 +1,34 @@
+From 49d7a90c159b12173ce202fb9b101465b87da96c Mon Sep 17 00:00:00 2001
+From: Guilhem Moulin <guilhem@fripost.org>
+Date: Sun, 15 Dec 2019 03:38:59 +0100
+Subject: [PATCH 2/2] tests/run: Don't redirect stderr by process substitution.
+
+This seems to cause timing issues.
+---
+ tests/run | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/tests/run b/tests/run
+index a34e4a9..4aa0685 100755
+--- a/tests/run
++++ b/tests/run
+@@ -202,11 +202,13 @@ prepare
+ interimap() { _interimap_cmd "interimap" "$@"; }
+ pullimap() { _interimap_cmd "pullimap" "$@"; }
+ _interimap_cmd() {
+- declare -a ENVIRON=() r=0
+- local script="$1"
++ declare -a ENVIRON=()
++ local script="$1" rv=0
+ shift
+ environ_set "local"
+- env -i "${ENVIRON[@]}" perl -I./lib -T "./$script" "$@" 2> >(tee "$STDERR" >&2)
++ env -i "${ENVIRON[@]}" perl -I./lib -T "./$script" "$@" 2>"$STDERR" || rv=$?
++ cat <"$STDERR" >&2
++ return $rv
+ }
+ interimap_init() {
+ local u="${1-remote}"
+--
+2.24.0
+
diff --git a/debian/patches/tests-t-Increase-timeout-from-2-to-5s-after-backgrou.patch b/debian/patches/tests-t-Increase-timeout-from-2-to-5s-after-backgrou.patch
new file mode 100644
index 0000000..76b678b
--- /dev/null
+++ b/debian/patches/tests-t-Increase-timeout-from-2-to-5s-after-backgrou.patch
@@ -0,0 +1,68 @@
+From a7517e35cf0c835fcb68db56d8634fab9b4d5f0d Mon Sep 17 00:00:00 2001
+From: Guilhem Moulin <guilhem@fripost.org>
+Date: Sun, 15 Dec 2019 03:35:51 +0100
+Subject: [PATCH 1/2] tests/*/t: Increase timeout from 2 to 5s after background
+ syncs.
+
+---
+ tests/condstore/t | 2 +-
+ tests/pullimap/t | 2 +-
+ tests/sync-live-multi/t | 2 +-
+ tests/sync-live/t | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tests/condstore/t b/tests/condstore/t
+index d4da50f..1963b2b 100644
+--- a/tests/condstore/t
++++ b/tests/condstore/t
+@@ -31,7 +31,7 @@ while [ $(date +%s) -le $timer ]; do
+ doveadm -u "$u" flags "$a" "$f" mailbox "INBOX" "${seqs//$'\n'/,}"
+ sleep "0.0$(shuf -n1 -i10-99)" # 10 to 99ms
+ done
+-sleep 2
++sleep 5
+
+ ptree_abort $PID
+ trap - EXIT INT TERM
+diff --git a/tests/pullimap/t b/tests/pullimap/t
+index 79da3e0..115432d 100644
+--- a/tests/pullimap/t
++++ b/tests/pullimap/t
+@@ -123,7 +123,7 @@ while [ $(date +%s) -le $timer ]; do
+ sleep "$s"
+ done
+
+-sleep 2
++sleep 5
+ ptree_abort $PID
+ trap - EXIT INT TERM
+
+diff --git a/tests/sync-live-multi/t b/tests/sync-live-multi/t
+index 9b129ec..ba7f326 100644
+--- a/tests/sync-live-multi/t
++++ b/tests/sync-live-multi/t
+@@ -96,7 +96,7 @@ done
+ # wait a little longer so interimap has time to run loop() again and
+ # synchronize outstanding changes, then terminate the processes we
+ # started above
+-sleep 2
++sleep 5
+
+ ptree_abort ${PID[@]}
+ trap - EXIT INT TERM
+diff --git a/tests/sync-live/t b/tests/sync-live/t
+index 19d1e08..5f5b291 100644
+--- a/tests/sync-live/t
++++ b/tests/sync-live/t
+@@ -65,7 +65,7 @@ done
+ # wait a little longer so interimap has time to run loop() again and
+ # synchronize outstanding changes, then terminate the process we started
+ # above
+-sleep 2
++sleep 5
+
+ ptree_abort $PID
+ trap - EXIT INT TERM
+--
+2.24.0
+