diff options
author | Guilhem Moulin <guilhem@fripost.org> | 2017-07-29 13:37:30 +0200 |
---|---|---|
committer | Guilhem Moulin <guilhem@fripost.org> | 2017-07-29 13:37:30 +0200 |
commit | b3b34342a2276619d321392e0f06114e13a6d46d (patch) | |
tree | 22d808c95f52de208d8caad1cf015d47552db436 /Makefile | |
parent | 99f085242ccb3ffdb903ce63d790b536d27176e8 (diff) | |
parent | 783954eaacec35d53674749e302c2ea6ac137935 (diff) |
Merge branch 'master' into debian
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 40 |
1 files changed, 24 insertions, 16 deletions
@@ -3,22 +3,30 @@ all: pullimap.1 interimap.1 # upper case the headers and remove the links %.1: %.md @pandoc -S -f markdown -t json "$<" | \ - jq ".[1][] |= if .t == \"Header\" then .c[2][] |= (if .t == \"Str\" then .c |= ascii_upcase else . end) else . end" | \ - jq " \ - def fixit: \ - if type == \"object\" then \ - if .t == \"Link\" then \ - if .c[2][0][0:7] == \"mailto:\" then . else .c[1][] end \ - else \ - map_values(fixit) \ - end \ - else if type == \"array\" then \ - map(fixit) \ - else \ - . \ - end \ - end; \ - map(fixit)" | \ + jq " \ + def fixheaders: \ + if .t == \"Header\" then \ + .c[2][] |= (if .t == \"Str\" then .c |= ascii_upcase else . end)\ + else \ + . \ + end; \ + def fixlinks: \ + if type == \"object\" then \ + if .t == \"Link\" then \ + if .c[2][0][0:7] == \"mailto:\" then . else .c[1][] end \ + else \ + map_values(fixlinks) \ + end \ + else if type == \"array\" then \ + map(fixlinks) \ + else \ + . \ + end \ + end; \ + { \"pandoc-api-version\" \ + , meta \ + , blocks: .blocks | map(fixheaders) | map(fixlinks) \ + }" | \ pandoc -sS -f json -t man -o "$@" install: |