diff options
author | Guilhem Moulin <guilhem@debian.org> | 2020-12-11 11:46:57 +0100 |
---|---|---|
committer | Guilhem Moulin <guilhem@debian.org> | 2020-12-11 11:46:57 +0100 |
commit | f2b70e9691adc09f6191751c2009f411199ec35d (patch) | |
tree | 9e7787f245396ffe380839e56df26e7d418c2f90 /Makefile | |
parent | bcb88ae0cdfa3548e3c650fd489fc49779e7235a (diff) | |
parent | a51f2efacebbf941585809853d1adbfddc165ac2 (diff) |
Merge tag 'v0.5.4' into debian/latest
Release version 0.5.4
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 18 |
1 files changed, 16 insertions, 2 deletions
@@ -16,7 +16,21 @@ $(MANUAL_FILES): $(BUILD_DOCDIR)/%: ./doc/%.md pandoc -f markdown -t json -- "$<" | ./pandoc2man.jq | pandoc -s -f json -t man -o "$@" test: - @./tests/run-all + ./tests/certs/generate + ./tests/run-all + +release: + @if ! git diff HEAD --quiet -- ./interimap ./pullimap ./Changelog; then \ + echo "Dirty state, refusing to release!" >&2; \ + exit 1; \ + fi + sed -ri "0,/^( -- .*) .*/ s//\1 $(shell date -R)/" ./Changelog + VERS=$$(dpkg-parsechangelog -l Changelog -SVersion 2>/dev/null) && \ + sed -ri "0,/^(our \\\$$VERSION\\s*=\s*)'[0-9.]+'\\s*;/ s//\1'$$VERS';/" \ + -- ./interimap ./pullimap && \ + git commit -m "Prepare new release v$$VERS." \ + -- ./interimap ./pullimap ./Changelog && \ + git tag -sm "Release version $$VERS" "v$$VERS" ## make html CSS="https://guilhem.org/static/css/bootstrap.min.css" BUILD_DOCDIR="$XDG_RUNTIME_DIR/Downloads" $(HTML_FILES): $(BUILD_DOCDIR)/%.html: ./doc/%.md $(HTML_TEMPLATE) @@ -58,4 +72,4 @@ uninstall: clean: rm -vf -- $(MANUAL_FILES) $(HTML_FILES) -.PHONY: all manual html doc test install uninstall clean +.PHONY: all manual html doc test release install uninstall clean |