diff options
author | Guilhem Moulin <guilhem@fripost.org> | 2019-11-13 20:11:20 +0100 |
---|---|---|
committer | Guilhem Moulin <guilhem@fripost.org> | 2019-11-13 20:11:20 +0100 |
commit | 65f42f56ba3529efe429d345aa378e2d8b71995e (patch) | |
tree | 03fed6141d3cef80d8d4c0bfc31c269b6b7c96b1 /Makefile | |
parent | 8f96256d9dd011ac63395c435a730002faa2f25d (diff) | |
parent | a8479a847118a2713ec69cc1fb667e5214956637 (diff) |
Merge branch 'master' into debian
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 27 |
1 files changed, 1 insertions, 26 deletions
@@ -5,32 +5,7 @@ manual: $(MANUALS) # upper case the headers and remove the links $(MANUALS): %: %.md - @pandoc -f markdown -t json -- "$<" | \ - jq " \ - def fixheaders: \ - if .t == \"Header\" then \ - .c[2][] |= (if .t == \"Str\" then .c |= ascii_upcase else . end)\ - else \ - . \ - end; \ - def fixlinks: \ - if type == \"object\" then \ - if .t == \"Link\" then \ - if .c[2][0][0:7] == \"mailto:\" then . else .c[1][] end \ - else \ - map_values(fixlinks) \ - end \ - else if type == \"array\" then \ - map(fixlinks) \ - else \ - . \ - end \ - end; \ - { \"pandoc-api-version\" \ - , meta \ - , blocks: .blocks | map(fixheaders) | map(fixlinks) \ - }" | \ - pandoc -s -f json -t man+smart -o "$@" + pandoc -f markdown -t json -- "$<" | ./pandoc2man.jq | pandoc -s -f json -t man+smart -o "$@" test: @./tests/run-all |