aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGuilhem Moulin <guilhem@fripost.org>2016-03-11 03:08:21 +0100
committerGuilhem Moulin <guilhem@fripost.org>2016-03-11 03:10:24 +0100
commit95787b188cc324fbdb6c6022d9750ba552591559 (patch)
treeb3705c5ce07f9b52a52b67555878bc0688b981f1 /Makefile
parent7fa59faf5b62eb108555fb8185eacbd1df13d44a (diff)
Convert pullimap's manpage to pandoc.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..7a56a47
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,29 @@
+all: pullimap.1
+
+# upper case the headers and remove the links
+%.1: %.md
+ @pandoc -S -f markdown -t json "$<" | \
+ jq ".[1][] |= if .t == \"Header\" then .c[2][] |= (if .t == \"Str\" then .c |= ascii_upcase else . end) else . end" | \
+ jq " \
+ def fixit: \
+ if type == \"object\" then \
+ if .t == \"Link\" then \
+ if .c[2][0][0:7] == \"mailto:\" then . else .c[1][] end \
+ else \
+ map_values(fixit) \
+ end \
+ else if type == \"array\" then \
+ map(fixit) \
+ else \
+ . \
+ end \
+ end; \
+ map(fixit)" | \
+ pandoc -sS -f json -t man -o "$@"
+
+install:
+
+clean:
+ rm -f pullimap.1
+
+.PHONY: all install clean