aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..36a24cd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+export prefix=/usr
+export sitelib=$(prefix)/share/perl5
+
+%:
+ dh $@
+
+ifneq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
+override_dh_auto_build:
+ dh_auto_build -- all-nodoc
+endif
+
+override_dh_auto_test:
+ # /dev/shm, the default, might be mounted with noexec
+ dh_auto_test --no-parallel -- TMPDIR=/var/tmp
+
+override_dh_installsystemduser:
+ dh_installsystemduser --no-enable