aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Moulin <guilhem@fripost.org>2017-07-28 00:29:46 +0200
committerGuilhem Moulin <guilhem@fripost.org>2017-07-28 00:29:46 +0200
commitb75b3740b7036cc182aaacbb869104e48bd7faba (patch)
tree821e539545b8317e87d516a28214efde50b6bb0e
parent3650b6714dd6e3df74b6c739dded7b6ddda79622 (diff)
parented76ee7723e232d288522db61e6ddabd6fd90b90 (diff)
Updated version 0.4 from 'upstream/0.4'
-rw-r--r--Changelog7
-rw-r--r--Makefile41
2 files changed, 32 insertions, 16 deletions
diff --git a/Changelog b/Changelog
index de6185d..2fd2f8e 100644
--- a/Changelog
+++ b/Changelog
@@ -1,3 +1,10 @@
+lacme (0.4) upstream;
+
+ * Fix generation of manpages with pandoc >=1.18
+ * Copy snippets/*.conf to /etc/lacme
+
+ -- Guilhem Moulin <guilhem@fripost.org> Fri, 28 Jul 2017 00:16:06 +0200
+
lacme (0.3) upstream;
+ When parsing config-cert files and directories (default "lacme-certs.conf
diff --git a/Makefile b/Makefile
index 3b61341..76057e2 100644
--- a/Makefile
+++ b/Makefile
@@ -5,28 +5,37 @@ all: ${MANPAGES}
# upper case the headers and remove the links
%.1: %.md
@pandoc -S -f markdown -t json "$<" | \
- jq ".[1][] |= if .t == \"Header\" then .c[2][] |= (if .t == \"Str\" then .c |= ascii_upcase else . end) else . end" | \
- jq " \
- def fixit: \
- if type == \"object\" then \
- if .t == \"Link\" then \
- if .c[2][0][0:7] == \"mailto:\" then . else .c[1][] end \
- else \
- map_values(fixit) \
- end \
- else if type == \"array\" then \
- map(fixit) \
- else \
- . \
- end \
- end; \
- map(fixit)" | \
+ jq " \
+ def fixheaders: \
+ if .t == \"Header\" then \
+ .c[2][] |= (if .t == \"Str\" then .c |= ascii_upcase else . end)\
+ else \
+ . \
+ end; \
+ def fixlinks: \
+ if type == \"object\" then \
+ if .t == \"Link\" then \
+ if .c[2][0][0:7] == \"mailto:\" then . else .c[1][] end \
+ else \
+ map_values(fixlinks) \
+ end \
+ else if type == \"array\" then \
+ map(fixlinks) \
+ else \
+ . \
+ end \
+ end; \
+ { \"pandoc-api-version\" \
+ , meta \
+ , blocks: .blocks | map(fixheaders) | map(fixlinks) \
+ }" | \
pandoc -sS -f json -t man -o "$@"
install: ${MANPAGES}
install -d $(DESTDIR)/etc/lacme
install -d $(DESTDIR)/etc/lacme/lacme-certs.conf.d
install -m0644 -t $(DESTDIR)/etc/lacme config/*.conf
+ install -m0644 -t $(DESTDIR)/etc/lacme snippets/*.conf
install -d $(DESTDIR)/usr/share/lacme
install -m0644 -t $(DESTDIR)/usr/share/lacme certs/lets-encrypt-x[1-4]-cross-signed.pem
install -d $(DESTDIR)/usr/lib/lacme