aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Moulin <guilhem@fripost.org>2018-04-26 16:50:11 +0200
committerGuilhem Moulin <guilhem@fripost.org>2018-04-26 20:31:51 +0200
commit5ea132288e4f83fa24ebf3f61b503e440aaccad5 (patch)
tree994f68bcc9a8af360e77c5cc79d4fe7f5981e368
parented76ee7723e232d288522db61e6ddabd6fd90b90 (diff)
Fix manpage generation with pandoc >=2.1
-rw-r--r--Changelog6
-rw-r--r--Makefile4
2 files changed, 8 insertions, 2 deletions
diff --git a/Changelog b/Changelog
index 2fd2f8e..a8ebfe6 100644
--- a/Changelog
+++ b/Changelog
@@ -1,3 +1,9 @@
+lacme (0.5) upstream;
+
+ * Fix manpage generation with pandoc >=2.1
+
+ -- Guilhem Moulin <guilhem@fripost.org> Thu, 26 Apr 2018 16:48:13 +0200
+
lacme (0.4) upstream;
* Fix generation of manpages with pandoc >=1.18
diff --git a/Makefile b/Makefile
index 76057e2..5d421bf 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ all: ${MANPAGES}
# upper case the headers and remove the links
%.1: %.md
- @pandoc -S -f markdown -t json "$<" | \
+ @pandoc -f markdown -t json "$<" | \
jq " \
def fixheaders: \
if .t == \"Header\" then \
@@ -29,7 +29,7 @@ all: ${MANPAGES}
, meta \
, blocks: .blocks | map(fixheaders) | map(fixlinks) \
}" | \
- pandoc -sS -f json -t man -o "$@"
+ pandoc -s -f json -t man+smart -o "$@"
install: ${MANPAGES}
install -d $(DESTDIR)/etc/lacme