aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Moulin <guilhem@fripost.org>2016-06-14 17:41:36 +0200
committerGuilhem Moulin <guilhem@fripost.org>2016-06-14 17:41:36 +0200
commit7572f83346d955270c99c023e0041c985494ee0d (patch)
treef4882da7129f9f8611af9501e5249784c1361296
parent2ad62692c51ef412810de3ed78d9aa18cd86b532 (diff)
parentfdfc319e8055f77938c87d096aaab913186b3582 (diff)
Merge branch 'master' into debian
-rw-r--r--Changelog5
-rw-r--r--INSTALL51
-rw-r--r--Makefile4
-rwxr-xr-xclient2
-rwxr-xr-xlacme2
-rwxr-xr-xlacme-accountd3
-rw-r--r--lacme-accountd.md4
-rw-r--r--lacme.md4
-rwxr-xr-xwebserver3
9 files changed, 69 insertions, 9 deletions
diff --git a/Changelog b/Changelog
new file mode 100644
index 0000000..b8d5780
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,5 @@
+lacme (0.1) upstream;
+
+ * Initial public release. Development was started in December 2015.
+
+ -- Guilhem Moulin <guilhem@guilhem.org> Tue, 14 Jun 2016 17:30:58 +0200
diff --git a/INSTALL b/INSTALL
new file mode 100644
index 0000000..935b052
--- /dev/null
+++ b/INSTALL
@@ -0,0 +1,51 @@
+lacme-accountd depends on the following Perl modules:
+
+ - Config::Tiny
+ - Crypt::OpenSSL::RSA (for PEM-encoded key material)
+ - Crypt::OpenSSL::Bignum (for PEM-encoded key material)
+ - Errno (core module)
+ - Getopt::Long (core module)
+ - JSON (optionally C/XS-accelerated with JSON::XS)
+ - List::Util (core module)
+ - MIME::Base64 (core module)
+ - Socket (core module)
+
+On Debian GNU/Linux systems, these dependencies can be installed with
+the following command:
+
+ apt-get install libconfig-tiny-perl libcrypt-openssl-rsa-perl libcrypt-openssl-bignum-perl libjson-perl
+
+
+lacme depends on OpenSSL and the following Perl modules:
+
+ - Config::Tiny
+ - Digest::SHA (core module)
+ - Errno (core module)
+ - Fcntl (core module)
+ - File::Temp (core module)
+ - Getopt::Long (core module)
+ - JSON (optionally C/XS-accelerated with JSON::XS)
+ - List::Util (core module)
+ - LWP::UserAgent
+ - LWP::Protocol::https (for https:// ACME directory URIs)
+ - MIME::Base64 (core module)
+ - Net::SSLeay
+ - POSIX (core module)
+ - Socket (core module)
+
+On Debian GNU/Linux systems, these dependencies can be installed with
+the following command:
+
+ apt-get install openssl libconfig-tiny-perl libjson-perl libwww-perl liblwp-protocol-https-perl libnet-ssleay-perl
+
+However Debian GNU/Linux users can also use gbp(1) from git-buildpackage
+to build their own package:
+
+ $ git checkout debian
+ $ AUTO_DEBSIGN=no gbp buildpackage
+
+Alternatively, for the development version:
+
+ $ git checkout debian
+ $ git merge master
+ $ AUTO_DEBSIGN=no gbp buildpackage --git-force-create --git-upstream-tree=BRANCH
diff --git a/Makefile b/Makefile
index f8084ed..4e5f06d 100644
--- a/Makefile
+++ b/Makefile
@@ -33,7 +33,9 @@ install: ${MANPAGES}
install -d $(DESTDIR)/usr/share/man/man1
install -m0644 -t $(DESTDIR)/usr/share/man/man1 lacme-accountd.1 lacme.1
install -d $(DESTDIR)/usr/bin
- install -m0644 -t $(DESTDIR)/usr/bin lacme-accountd lacme
+ install -m0644 -t $(DESTDIR)/usr/bin lacme-accountd
+ install -d $(DESTDIR)/usr/sbin
+ install -m0644 -t $(DESTDIR)/usr/bin lacme
clean:
rm -vf ${MANPAGES}
diff --git a/client b/client
index 810cd35..2566c9b 100755
--- a/client
+++ b/client
@@ -1,7 +1,7 @@
#!/usr/bin/perl -T
#----------------------------------------------------------------------
-# ACME client
+# ACME client written with process isolation and minimal privileges in mind
# Copyright © 2015,2016 Guilhem Moulin <guilhem@fripost.org>
#
# This program is free software: you can redistribute it and/or modify
diff --git a/lacme b/lacme
index 12fb181..f6d2b7a 100755
--- a/lacme
+++ b/lacme
@@ -1,7 +1,7 @@
#!/usr/bin/perl -T
#----------------------------------------------------------------------
-# ACME client
+# ACME client written with process isolation and minimal privileges in mind
# Copyright © 2016 Guilhem Moulin <guilhem@fripost.org>
#
# This program is free software: you can redistribute it and/or modify
diff --git a/lacme-accountd b/lacme-accountd
index 704f836..fbf1bcb 100755
--- a/lacme-accountd
+++ b/lacme-accountd
@@ -1,7 +1,8 @@
#!/usr/bin/perl -T
#----------------------------------------------------------------------
-# ACME client (account key manager)
+# ACME client written with process isolation and minimal privileges in mind
+# (account key manager)
# Copyright © 2016 Guilhem Moulin <guilhem@fripost.org>
#
# This program is free software: you can redistribute it and/or modify
diff --git a/lacme-accountd.md b/lacme-accountd.md
index 54b0ed7..81c0802 100644
--- a/lacme-accountd.md
+++ b/lacme-accountd.md
@@ -5,7 +5,8 @@
Name
====
-lacme-accountd - [ACME] client (account key manager)
+lacme-accountd - [ACME] client written with process isolation and
+minimal privileges in mind (account key manager)
Synopsis
========
@@ -129,7 +130,6 @@ execute [`lacme`(1)] remotely:
~$ ssh -oExitOnForwardFailure=yes -tt -R /path/to/remote.sock:/run/user/1000/S.lacme user@example.org \
sudo lacme --socket=/path/to/remote.sock new-cert
-
See also
========
diff --git a/lacme.md b/lacme.md
index 04f2836..b7a7f49 100644
--- a/lacme.md
+++ b/lacme.md
@@ -5,7 +5,8 @@
Name
====
-lacme - [ACME] client
+lacme - [ACME] client written with process isolation and minimal
+privileges in mind
Synopsis
========
@@ -342,7 +343,6 @@ Examples
~$ sudo lacme new-cert
~$ sudo lacme revoke-cert /path/to/server/certificate.pem
-
See also
========
diff --git a/webserver b/webserver
index df4e3ba..e97fe00 100755
--- a/webserver
+++ b/webserver
@@ -1,7 +1,8 @@
#!/usr/bin/perl -T
#----------------------------------------------------------------------
-# ACME client (webserver component)
+# ACME client written with process isolation and minimal privileges in mind
+# (webserver component)
# Copyright © 2015,2016 Guilhem Moulin <guilhem@fripost.org>
#
# This program is free software: you can redistribute it and/or modify