diff options
author | Benjamin Tietz <benjamin@micronet24.de> | 2018-11-28 20:20:54 +0100 |
---|---|---|
committer | Guilhem Moulin <guilhem@fripost.org> | 2020-08-03 21:54:29 +0200 |
commit | 0cf8517bea1e939d7054e682cde24767e7ed6e04 (patch) | |
tree | 4dff753ccb0b24ccdb838bc684c7f487bce7deb4 /Makefile | |
parent | 89f8c948d7b39314d7fc997643874adc6be92462 (diff) |
factor out jq-script from Makefile
the script is just a plain copy, but now accessible without make
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 25 |
1 files changed, 1 insertions, 24 deletions
@@ -5,30 +5,7 @@ all: ${MANPAGES} # upper case the headers and remove the links %.1: %.md @pandoc -f markdown -t json "$<" | \ - jq " \ - def fixheaders: \ - if .t == \"Header\" then \ - .c[2][] |= (if .t == \"Str\" then .c |= ascii_upcase else . end)\ - else \ - . \ - end; \ - def fixlinks: \ - if type == \"object\" then \ - if .t == \"Link\" then \ - if .c[2][0][0:7] == \"mailto:\" then . else .c[1][] end \ - else \ - map_values(fixlinks) \ - end \ - else if type == \"array\" then \ - map(fixlinks) \ - else \ - . \ - end \ - end; \ - { \"pandoc-api-version\" \ - , meta \ - , blocks: .blocks | map(fixheaders) | map(fixlinks) \ - }" | \ + jq -f fixman.jq | \ pandoc -s -f json -t man+smart -o "$@" install: ${MANPAGES} |