aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGuilhem Moulin <guilhem@fripost.org>2016-03-02 18:19:04 +0100
committerGuilhem Moulin <guilhem@fripost.org>2016-03-02 18:19:04 +0100
commit97369c2e6dce66881d673ba308acd069c08a8776 (patch)
tree3946b0216071d0b2e47b805ac2a19bef685a6c38 /Makefile
parentc4db1e4a18a13f7db04dbbd10663f0edba7d206d (diff)
parent63633fd91bcc97217f2ac45ba602d752e8fbaafd (diff)
Merge branch 'master' into debian
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..5df5627
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+all:
+
+install:
+ install -d $(DESTDIR)/etc/letsencrypt-tiny
+ install -m0644 -t $(DESTDIR)/etc/letsencrypt-tiny config/*.conf
+ install -d $(DESTDIR)/usr/share/letsencrypt-tiny
+ install -m0644 -t $(DESTDIR)/usr/share/letsencrypt-tiny lets-encrypt-x[12]-cross-signed.pem
+ install -d $(DESTDIR)/usr/lib/letsencrypt-tiny
+ install -m0755 -t $(DESTDIR)/usr/lib/letsencrypt-tiny client webserver
+ install -d $(DESTDIR)/usr/share/man/man1
+ install -m0644 -t $(DESTDIR)/usr/share/man/man1 letsencrypt-accountd.1 letsencrypt.1
+ install -d $(DESTDIR)/usr/bin
+ install -m0644 -t $(DESTDIR)/usr/bin letsencrypt-accountd letsencrypt
+
+.PHONY: all install