aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile50
1 files changed, 38 insertions, 12 deletions
diff --git a/Makefile b/Makefile
index 7fd32f8..ad586ab 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,41 @@
-all:
-
-install:
- install -d $(DESTDIR)/etc/letsencrypt-tiny
- install -m0644 -t $(DESTDIR)/etc/letsencrypt-tiny config/*.conf
- install -d $(DESTDIR)/usr/share/letsencrypt-tiny
- install -m0644 -t $(DESTDIR)/usr/share/letsencrypt-tiny lets-encrypt-x[1-4]-cross-signed.pem
- install -d $(DESTDIR)/usr/lib/letsencrypt-tiny
- install -m0755 -t $(DESTDIR)/usr/lib/letsencrypt-tiny client webserver
+MANPAGES = lacme-accountd.1 lacme.1
+
+all: ${MANPAGES}
+
+# upper case the headers and remove the links
+%.1: %.md
+ @pandoc -S -f markdown -t json "$<" | \
+ jq ".[1][] |= if .t == \"Header\" then .c[2][] |= (if .t == \"Str\" then .c |= ascii_upcase else . end) else . end" | \
+ jq " \
+ def fixit: \
+ if type == \"object\" then \
+ if .t == \"Link\" then \
+ if .c[2][0][0:7] == \"mailto:\" then . else .c[1][] end \
+ else \
+ map_values(fixit) \
+ end \
+ else if type == \"array\" then \
+ map(fixit) \
+ else \
+ . \
+ end \
+ end; \
+ map(fixit)" | \
+ pandoc -sS -f json -t man -o "$@"
+
+install: ${MANPAGES}
+ install -d $(DESTDIR)/etc/lacme
+ install -m0644 -t $(DESTDIR)/etc/lacme config/*.conf
+ install -d $(DESTDIR)/usr/share/lacme
+ install -m0644 -t $(DESTDIR)/usr/share/lacme lets-encrypt-x[1-4]-cross-signed.pem
+ install -d $(DESTDIR)/usr/lib/lacme
+ install -m0755 -t $(DESTDIR)/usr/lib/lacme client webserver
install -d $(DESTDIR)/usr/share/man/man1
- install -m0644 -t $(DESTDIR)/usr/share/man/man1 letsencrypt-accountd.1 letsencrypt.1
+ install -m0644 -t $(DESTDIR)/usr/share/man/man1 lacme-accountd.1 lacme.1
install -d $(DESTDIR)/usr/bin
- install -m0644 -t $(DESTDIR)/usr/bin letsencrypt-accountd letsencrypt
+ install -m0644 -t $(DESTDIR)/usr/bin lacme-accountd lacme
+
+clean:
+ rm -vf ${MANPAGES}
-.PHONY: all install
+.PHONY: all install clean